PPS: Using Windows 10 With the Valant Suite EHR

This article applies to the Private Practice Suite

The default browser that comes with Microsoft Windows 10 is Edge. Since Silverlight will not work with Edge, Windows 10 users will need to download Mozilla Firefox or Internet Explorer to be able to use the Valant Suite EHR.

The icon for Internet Explorer and Microsoft Edge are rather similar. Please ensure that you are using the correct icon for Internet Explorer to access the Valant Suite EHR.
Please read Valant Suite Computer Settings for a complete overview of how to configure your computer and browser.

Was this article helpful?

header-top-left-border Created with Sketch.
header-top-right-border Created with Sketch.