PPS: Valant Suite Computer Settings

This article applies to the Private Practice Suite


Users need to follow the instructions contained in the below list of articles before using the Valant Suite EHR for the first time. The latest version of  Mozilla Firefox ESR Version 52, Firefox ESR Version 52 for Mac and the latest version of Internet Explorer are the recommended browsers.

  1. Installing the Silverlight Plug-in
  2. Installing Adobe Acrobat Reader DC
  3. Installing the Valant Word Add-in on a PC
  4. Enabling the Valant Word Add-in in Word

The final step is to configure the browser being used (choose one):

Related Articles

Suite Hardware Requirements

Suite Software Requirements

Was this article helpful?

header-top-left-border Created with Sketch.
header-top-right-border Created with Sketch.