PPS: Suite Software Requirements

This article applies to the Private Practice Suite


For browser configuration instructions please consult Valant Suite Computer Settings

The Valant Private Practice Suite uses the latest technology to ensure security and reliability. This includes Secure Socket Layer (SSL) 3.0 protocol with 128 bit encryption for secure communications and JavaScript for a responsive interactive experience. We recommend always using the most up-to-date browser for the highest level of security.

The Software Requirements for the Vālant EMR are as follows:

PC Users:

Operating System:

Windows 7 Professional SP1 or higher
Windows 7 Enterprise SP1 or higher
Windows 7 Ultimate SP1 or higher
Windows 8.x (The standard version of Windows 8 cannot be added to a domain)
Windows 8.x Professional
Windows 8.x Enterprise
Windows 10.x

Notes:

Microsoft Windows XP Professional is not HIPAA compliant, therefore it is not a supported operating system
Microsoft Vista is not HIPAA compliant, therefore it is not a supported operating system
Windows RT is not a supported operating system for the core EMR
Mobile Notes is platform free and not restricted by browser requirements.

Internet Browser:

Internet Explorer 11 or higher
Mozilla Firefox v52.8 (ESR)
Google Chrome is not a supported web browser
Microsoft Edge is not a supported web browser
Opera is not a supported web browser
Safari is not a supported web browser

Additional Software:

Vālant Word Add-in (for PC only)
Adobe Reader v9.x or higher
Microsoft Silverlight v5 or higher (Install/upgrade)
Microsoft Word 2007 or higher (Word Starter 2007 does not support macros, therefore it is not supported)
Adobe Flash Player v12.x or higher (necessary for e-learning content - download)

Mac Users:

Operating System:

Mac OS X 10.7.5 (Intel-based) - macOS Mojave- 10.14
Note: macOS Catalina 10.15 does not support Microsoft Silverlight and cannot be used with the Valant Private Practice Suite.

Internet Browser:

Mozilla Firefox v52.8 (ESR) (download)
Silverlight will not run on Firefox in 64-bit on a Mac, which is the default setting
Apple Safari and Google Chrome are not a supported web browsers
Due to memory limitations, e-learning content is not supported when using iPads

Additional Software:

Adobe Reader v9.x or higher
Microsoft Silverlight v5 or higher (Install)
Microsoft Word for Mac 2008 or higher
Microsoft Word Starter 2008 does not support macros, therefore it is not supported
Adobe Flash Player v12.x or higher (necessary for e-learning content - download)
 

NOTE:  Customers with the EasyBilling module and use our partner, Relay Health, will require access to a PC with IE v8.x or higher to check the status of submitted claims

Was this article helpful?

header-top-left-border Created with Sketch.
header-top-right-border Created with Sketch.